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Premiere 6.0

Although everything has been redesigned, nothing in Premiere 6.0 will be unfamiliar to Premiere stalwarts. Palettes now look more Photoshop-like and there’s a new Effects Controls palette that
looks very After Effects-ish.

t’s been a good long while
since Premiere 5 first
appeared on the scene –
about two-and-a-half
years, in fact. In that time

it’s been revised and patched quite a bit
so that the version now sitting on hard
drives all over the world is 5.1c, but
despite all the tweaks and changes
(including the “FireWire DV Device” plug-
ins) it’s never been abundantly happy
handling DV.

And that’s been to its detriment,
because those two-and-a-half years have
seen the explosion of DV into the lives of
video professionals and hobbyists and
many of them, particularly those with
Macs, have turned away from the ageing
Premiere in favour of new, DV-savvy
applications, most notably Apple’s own

Final Cut Pro 1.2.5. But Adobe has finally
fought back with the long-overdue
release of Premiere 6.0. Better late, as
they say, than never.

Widescreen
Opening the application brings up a
nearly-familiar Project Settings dialogue
which enables you to define exactly
what sort of project you’ll be working on.
The presets are for both PAL and NTSC
DV, in both standard (4:3) and
widescreen (16:9) ratios with either
32kHz or 48kHz sound. There are also
presets for “multimedia” and for
analogue NTSC and PAL and, though not
officially notified, the settings supplied
by Pinnacle for its MotionDC30 and
DC30+ capture cards also seem to work
just fine. Fine-tuning the settings has

been made easier by the redesign and
getting everything just as you want it
seems slightly more straightforward
than before.

Once open, Premiere 6.0 looks very
familiar, and yet strangely different. The
project bin has been redesigned to make
organising clips a little more efficient
and clips can now be played at
thumbnail size in the Project window,
making finding the right one even
quicker and easier. The same thumbnail
viewer also enables you to set the
“poster frame” that will show in the bin
window. Usually, the icon for the clip is
the first frame, but that’s often not very
helpful – this feature lets you choose a
more meaningful frame.

The palettes (which are now very
Photoshop-esque) have been redesigned
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The transitions palette has been neatened up with transitions grouped in folders to make them easier to find. Video and
audio filters are similarly neatly organised.

It’s not a new application, but it’s new to Premiere 6.0. Now you can
add professionally composed music, tailored to your exact needs.

To help you to visualise projects there’s a storyboard window now
so you can make Premiere 6.0 work just like iMovie.

so that transitions are now organised in
folders rather than one long confusing
list. Tabs have been added in the same
window for audio and video filters
palettes, so that both can be accessed
and used with the same ease as
transitions. Instead of having to select a
clip in the timeline and then going up to
the menus, now you can just open up
the palette, find the effect you want and
then drag it to the clip.

Once the effect is in place it can be
adjusted by means of a very After Effects-
like Effects Controls palette where the
effect’s parameters can be set, changing
over time if you wish using
automatically-added keyframes (you
don’t have to get involved with the nitty-
gritty – just move the playhead and
change the settings and Premiere will 
do the rest).

There are some other tweaks to the
main screen, too. The monitor window is
neater and can jump from one screen to
two screen to trim view at the click of a
button, to suit your editing needs. The
timeline has been tidied, so that as well
as the neat effects-adding thing
described above you can now get direct
access to keyframes on the timeline for

more intuitive control over the way the
effects change over time.

Adobe has acknowledged that you’ll
need different screen layouts for different
stages of the job and has provided a set
of handy workspaces that automatically
fill your monitor screen with everything
you need. Let’s say, for instance, that
you’ve finished the main edit and you’re
mixing the audio tracks – simply select
the Audio workspace and you get just
the project bin, the new audio mixer (of
which more in a moment), a single
monitor window and the timeline. There
are three other presets (single-track
editing, A/B editing and effects) and you
can save your own if you want to (you
mad eccentric, you).

Capturing clips
But we’re getting ahead of ourselves.
Here we are looking at the main screen
and we haven’t even captured any clips.
Clip capture, especially from DV, was one
of Premiere 5’s weaknesses, but that’s
been very thoroughly addressed here.
The capture window has been revamped
to enable direct access to the capture
settings (rather than leaving you to find
your way through the menus as before)

and device control has been elevated to
new and lofty heights.

One of the main problems faced by 
all capture software is that all MiniDV
camcorders are not created equal. Each
of the manufacturers has its own way 
of doing things and sometimes chooses
to do things differently from model to
model within its own range. The result
is that device control from capture
software is rarely 100% reliable.

Adobe has got round this by analysing
the quirks, foibles and idiosyncrasies of
every camcorder currently available and
describing them in an XML file which
Premiere 6.0 uses to tell it how to control
any given camcorder. All you need to do
is to select the make and model of your
camcorder and everything should be
hunky-dory.

In our tests, everything was, indeed,
hunky-dory, even when using a newly
released JVC GR-DV2000 for which there
was no specific description available. And
any problems we might have had
wouldn’t have been a problem for

There was never anything
intuitive or simple about the
“rubber band” method for
adjusting audio levels in
Premiere. You can still do it that
way, but Premiere 6.0 comes
with these handy audio faders.
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long because Adobe promises to make
new XML files available on its website to
take account of new models as soon as
they’re released.

Batch capture is surprisingly easy, too.
In theory, it’s always been simple – you
play through your source tape, marking
the in and out points of the clips you
want as you go, and logging the clip
name. When you’ve finished, tell the
software to capture the whole batch
while you go and feed the cat.

Now that DV is widespread, this sort
of thing is a real possibility for everyone,
not just owners of fancy video-editing
decks, because device control is part of

the deal with a FireWire connection. But
for some reason it’s never been that
simple. Final Cut Pro 1.2.5, for example, is
very temperamental about batch capture
and will only do it on certain tapes, on
certain camcorders, on certain days,
seemingly at random. But Premiere 6.0
whizzed through the job without a
single glitch, dropped frame, or “not
enough material on source tape to
capture handle” error message. Adobe’s
claims of “robust DV support” are not, it
would appear, exaggerated.

Meanwhile, back at the project, we
met another addition that will really help
speed up your work. There are times

during a complex project when there’s so
much material flying around that it’s
difficult to keep track of all the settings.
The project might be standard 4:3 DV,
but some of the clips might have been
sourced from analogue video and
captured using different settings. And
what about the output, what’s that
going to be? 

It used to be a matter of selecting
each clip in turn and calling up
information about it to determine its
size, frame rate, etc, but now there’s a
Settings Viewer which shows everything
you need to know in one handy window.
You can scroll through the list of clips,
checking each one in turn and the
software will even highlight in red any
which don’t match the project settings,
warning you they’ll have to be rendered
to make them fit in. It’s a real boon.

Audio control has for a long time been
something of a joke on video-editing
packages, relying on a peculiar “rubber
band” method for adjusting levels (you
add points to a line representing the
audio level and then drag them up and
down to create your fades). Premiere 6.0
finally brings audio control out of the
dark ages by adding a virtual mixing
desk which works in much the same way
as a real mixing desk.

Putting a rough cut together can be a
tiresome task on a proper timeline and it
can be difficult to get a feel for the

Integrating CG animation into real-life footage is
simple. Start by putting your real-world master shot
onto video track V1. When you render the animation,

make sure you render it with an alpha channel (a fourth,
invisible masking channel) so that the background will be
transparent. Lay the animation on the superimpose track, V2.
It will obscure the other footage for the moment.

1 Select the animation clip by clicking on it and then
go to the Clip menu. Select Video Options –
Transparency (or click CC-G) to open up this dialogue.

Our Key Type is a Black Alpha Matte which we chose from the
pop-up menu. To check what the effect will look like, click on
the peeled-page icon under the sample window.

2 Back at the timeline, render and preview the effect
by hitting the Enter key and your computer-
generated animation will be interacting with the

real world. To let everyone see it, go to File > Export Timeline >
Save For Web. Cleaner EZ 5 will open up, so just choose a
setting from the pop-up and let it get on with recompressing
your project. It will even generate the HTML code you need.

3

Tutorial 1: Combining animation with real-world footage
Premiere 6.0’s compositing tools still aren’t as flexible as those in Final Cut Pro, but that’s because you’re supposed to

buy After Effects for that sort of thing. Nevertheless, you can still do some nifty effects work.

The preset workspaces in Premiere 6.0 are a real time saver. If you’ve got your edits where you want them and you just want to fine-tune the
sound, switch to the audio workspace and everything you need will be neatly laid out for you.
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structure of the project. Premiere 6.0
now has a storyboard feature so you can
drag icons representing the clips into the
order you want them in one, easy-to-see
window (it’s not entirely unlike using
iMovie, to be honest).

When you’re happy with the structure
you can click Automate To Timeline and
the clips will be assembled for you.

Particularly handy is the fact that if you
have an audio track you can go through
it, tapping the space bar to place a
marker whenever you feel a cut would 
be nice and then, when you send your
storyboard to the timeline, the cuts will
all be placed at the markers. A brief
session of slip editing to get exactly the
right parts of each clip on the timeline
and you’ve compiled a lovely montage to
music in less time than it would usually
take to build your first rough cut.

Output
And then, eventually, it’s all done. The
basic editing is as powerful and yet
straightforward as ever with all the
necessary tools (slip, slide, roll, ripple,
razor, etc) easily accessible. Adobe now
recognises that video won’t just be
output to tape but that it will be used on
the Web, on CDs – just about anywhere,
in fact. And to make it easy to present
your footage in exactly the right format,
Premiere 6.0 comes complete with a cut-
down version of Terran Interactive’s
Cleaner 5, called Cleaner 5 EZ.

If you want to prepare your project for
the Web, all you need do is select Save
For Web from the File menu and Cleaner
5 EZ will launch, run through your
options for you and get on with the job,
all without you having to quit Premiere.

Two-and-a-half years is a long time in
computer software terms and Premiere
lost a lot of ground during that time, but
Adobe has pulled out all the stops and
Premiere 6.0 puts it back up there at the
top where a great many people think it
deserved to be all along.

FCP does many things better
(Premiere’s compositing and layer
animation is still weak, for instance – you
need After Effects for that) but it costs a
good £300 more so you’d expect it to. But
the stalwarts have been rewarded –
Premiere 6.0 is a winner. MF
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MacFormat verdict

score

It was worth the wait and Premiere
finally has the “robust DV support” it’s
been lacking as well as a raft of other
useful features. A superb application in
every way.

Working the in the A/B Editing workspace, drop the
clip to be inserted on the other V1 track (in this case
V1A). Then drag one of the Iris transitions (we chose

Iris Round) onto the transition track and stretch it to the
length you want.

1 Double click on the transition on the timeline to
open up the Settings dialogue box. Click the A-B box
if the windows are round the wrong way (it changes

the direction of the transition). Set the Start and End to the
same size using the sliders and drag the circle round the
screen so that you can see whatever it is you want to see.

2 If you need the window to be in a specific place you
could also use Clip > Video Options > Motion to
move the inserted clip to the right place on the

screen and to re-scale it so that it fits exactly into the window
you want.

3

Tutorial 2: Picture-in-Picture effects using transitions
In the manuals for previous versions of Premiere there was a little trick you could do to get a picture-in-picture effect

using a transition rather than fancy masking techniques. It still works, but it’s not in the manual any more.

To save you from too much head scratching while
you wonder what format all your media is in,
there’s a handy settings viewer so you can check
that everything matches.

Changing capture settings used to be a chore, but now they’re easily accessible from
the capture window.

A nice music bed can make all the
difference to a project, but finding the
a royalty-free track of exactly the
right style and precisely the right
length can be a nightmare.

At least it used to be. There’s an extra
CD-ROM in the box called Smart-
Sound Quicktracks by Sonic Desktop
Software, which is an ingenious add-
on that can take any of a large
number of pieces of specially
composed and recorded music and
tailor them to your exact needs.

Let’s say, for instance, that you
need a lazy jazz intro to run under
your titles. You’ve already done the
title sequence which is 34 seconds
and 12 frames long. Ordinarily, finding
a piece that fits the bill would be hard
enough, but finding something of
exactly the right length would be
nearly impossible.

But the Wizard that controls
SmartSound makes it simple. Go to
File > New > SmartSound and follow it
through. You make a couple of choices
about the style and content of the
music you want, type in the length
you need and off it goes, making a
music file for you.

The results aren’t ever going to get
an Oscar for Best Original Film Score,
but they can add a bit of pizzazz to a
project for virtually no effort at all.
And if you should need more musical
options you can buy whole CDs full of
additional tracks from Sonic’s website.

MUSIC, MAESTRO, PLEASE
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